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Import of Images to Imaris  
A shorter video tutorial you can find at 
https://imaris.oxinst.com/learning/view/article/importing-data-into-imaris 

1 General Guidance 
It is recommended to try first to import the native file format of the acquisition device. If 
supported by Imaris this will give you the best experience since you can expect to preserve 
dimensions, calibration, and channel colours of the native format. 
You can find the supporter file formats at ‘Imaris main menu -> Help -> Preface -> Getting Started 
-> Supported File Formats’ 
 
Which Import Path to use:  
 
Imaris Arena 

If you have only a limited number of datasets to be imported in one go. 
Imaris Surpass Fiji Plugins 

For files were the Imaris reader fail completely 
Imaris File Converter 

For batch converts of many files. 
On machines you have no Imaris license, or you like not to block a license for the 
conversion. 
If Imaris can detect the format but still has problems to import correctly. 

2 Import using Imaris Arena 
If the location of the dataset cannot be already seen in Arena add the folder with the files to be 
converted to your Arena view using the ‘Observe Folder' button 

 
The Arena file browser of the main Imaris program will show you the thumbnails of the detected 
datasets.  
Tip: if you do not see the files or folders immediately press ‘CTRL – F5’ to refresh the view. 

1. With a double click or ‘RIGHT-MOUSE -> Convert to Native Imaris File Format’ it will be 
automatically converted and an IMS file will be saved to the same directory. 
Imaris may ask to enter the Voxels size if it could not extract it. 

 
2. Double click on the Thumbnail to open the IMS file in Imaris Surpass and check for 

correct dimensions and calibration data at ‘Surpass main menu ->  Edit –> Image 

https://imaris.oxinst.com/learning/view/article/importing-data-into-imaris
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Properties -> Geometry’

 
• If the Voxels sizes [1] or time calibration [2] is not correct you can edit them directly in 

the dialogue. 
• If size in X Y Z or T [3] or the number of channels [4] is not correct you can maybe fix 

this by using the File Series Reader.  
• If the channel colours are not correct you may click on the channel tabs [4] and 

correct them. 
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• Alternatively, you can come here by clicking in the name of the channel the ‘Display 
Adjustemt’ windows. ‘Surpass main menu -> Edit -> Show Display Adjustment’

 
 

 
By default, files with the same base name and size are stored into the same dataset. 
If the name contains only one running number, it is interpreted as a Z stack or time series. 
If the name contains multiple running number leaded by one of the below characters, the 
characters determine which dimensions are used. 
_C### Channels 
_T### Time Points 
_Z### Z Slices 
_X### X Slices 
_Y### Y Slices 
 
### = a running number 
 
If the files are not automatically sorted into the correct dimensions by Arena please read the 
chapter ‘File Series Reader’ 

2.1 File Series Reader 
The Imaris File Series Reader is a tool to handle series of numbered files. It allows you to group 
the files into datasets with the desired number of sections, channels and time points. The names 
and sizes of the files are used to arrange them. 
 
- Datasets which files are stored in multiple directories are not supported 
- It is available for plain Tiff files only, not e.g OME TIFF. Tiff files were Imaris finds metadata 

about the organisation of the dataset cannot be handled. 
- It is recommended to store the files of different datasets into sperate directories to simplify 

the task. 
 
The File Series Reader can be started from Arena on a thumbnail ‘RIGHT-MOUSE -> Configure 
File Series’ 
Please note that you can as well use the tool from Imaris File Converter‘ with a selected input file 
‘Settings…’ 

 
When started you need chose how the type of the naming of the files 

 
- If the file name has multiple running numbers for different dimensions chose ‘File Names with 

Delimiter’ e.g. 
retina_Ch0_layer000.tif    
retina_Ch0_layer001.tif 
retina_Ch0_layer002.tif    
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retina_Ch0_layer003.tif    
retina_Ch1_layer004.tif    
retina_Ch1_layer005.tif 
retina_Ch1_layer006.tif    
retina_Ch1_layer007.tif    
retina_Ch1_layer008.tif    
retina_Ch0_layer009.tif 
retina_Ch0_layer010.tif 

 
retina_ is the base name. Only files with this base name will be converted. 
Ch0 contains the running number for the channels 
layer001 contains the running number for the layers (slices). 
 

- If the files with the identical base name have one running number chose the Tab ‘File Names 
without Delimiter’ e.g.: 
retina_001.tif    
retina_002.tif    
retina_003.tif    
retina_004.tif   
retina_005.tif 
retina_006.tif 
retina_007.tif    
retina_008.tif    
retina_009.tif    
retina_010.tif 

 
retina_ is the base name. Only files with this base name will be converted. 
001 is a single running number for all files of the dataset 
 

Notes:  
 
- It is recommended to store the files of different datasets into sperate directories to simplify 

the task. 
- Datasets which files are stored in multiple directories are not supported 

 

2.1.1 File Names with Delimiter 
To be used if filenames contain multiple running numbers, e.g. retina_Ch0_layer000.tif 
 
The TIFF reader uses some patterns _C?number _T?number _S?number. That _[letter] codes are 
used to assign the different dimensions and sort the files automatically into channels, time points, 
slices etc. 
 
_C?number -C _CH _W Channel 
_T?number   Time 
_Z?number -Z _S  Slice 
_X?number -Y   Column 
_Y?number -Y   Row 
 
The ? can be any character or absent (_Cnumber) 
It does not distinguish between upper and lower case. 
The letter codes you can change at ‘Preferences – File Conversion’ 
 
If the automatic assignment does not work, you can use the ‘Series Reading Sequence’ tool to 
further tune it for specific files. 
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Imaris will show the filename and at the place of the running number a menu to select how the 
number should be interpreted: 
BLANK Ignore 
X  Slices 
Y  Slices 
Z  Slices 
C  Channels 
T  Timepoints 
F (Split) Split the files into the next dataset if the number changes. 
 
Below the number of items are shown which will be assigned to the chosen dimensions. In the 
screenshot this are 2 channel and 5 Z layers. 

 
The table ‘File Arrangement’ shows a preview of the resulting first dataset which will be created. 
 
Here are a few examples: 
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First number T, second number Z -> 1 datasets with 1 channel, 2 time points and 5 Z layers will 
be created. 
 

 
First number Z, second number T -> 1 datasets with 1 channel, 2 Z layers and 5 timepoints will 
be created. 
 

 
First number ‘F- (Split) , second number Z -> 2 datasets with 1 channel and 5 Z layers will be 
created. Please note that the table show always only the layout of the first IMS dataset. 
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First number C, second number T -> 1 dataset with 2 channels, 5 time points and 1 Z layer will 
be created. 

2.1.2 File Names without Delimiter 
To be used if filenames contain a single running numbers, e.g. retina_000.tif 

 
[1] Oder to loop inside the dimensions.  
The available settings are: 

BLANK Ignore 
X  Slices 
Y  Slices 
Z  Slices 
C  Channels 
T  Timepoints 
F (Split) Not needed. May crash Imaris when set! 

 
At [1] you can set the dimensions used for the dataset and in which order the files are assigned 
to them. 
At [2] you can set the number of items which will be assigned to the dimension above. 
In the above screenshot this is 1 dataset with 1 channel and 10 Z layers. 
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If you use multiple of the entries Imaris loops through the dimensions and assigns specified 
number of files to them in each round. The most right entry is for the inner loop and the most left 
for the outer. First the files with consecutive numbers will be added to the inner loop before the 
next dimension to the left starts to get filled. 
 
Here are some examples:  
 

 
Inner loop will be used for 2 channels. So files 01 and 02 go into the two channels of Z layer 1, 
time point 1. Middle loop is for Z layers so the files 03 and 04 go into Z layer 2, into the two 
channels. Now all dimensions of the inner two loops are filled and the outer loop starts to fill the 
second time point in the same order as the first one. 
[1] Imaris found 10 files with the same base name but we now use only 8. That means something 
is wrong with our configration of the dimensions, some files were lost after acquisition or the base 
name was not correctly detected. 
 

 
The inner loop will be used for 2 Z layers. So file 01 and 02 goes into the two layers of the 
channel 1. Since Z can hold only two items the files 03 and 04 go into the the second channel. 
Since there are 5 channels to be filled this is repeted for the remaining channels. 
The third loop is not used in this example since no dimension is assigend to the most right entry. 
 

2.1.3 Voxel Size and Channel colours 
At the bottom of the window you find the voxel size. 
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Set the Voxel size to have the correct calibration of the dataset. You may need to open the 
original dataset in the acquisition software to find the correct values. The calibration is very 
important to set before you start any analysis of the dataset. For a 2D dataset use 1. 0 will be 
not accepted by Imaris. 
The units, here micrometer, are a global setting in Imaris main menu ‘Preferences -> Display -> 
Unit of Length’. 
Note: The time calibration you must set after the conversion in Surpass main menu ‘Edit -> Image 
Properties… -> Geometry -> Time Point’. 
 
Typically, all channels will be displayed in red. Please open the dataset in ‘Surpass main menu ->  
Edit –> Image Properties -> Geometry -> Channel #’. 
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Alternatively, you can come here by clicking in the name of the channel the ‘Display Adjustemt’ 
windows. ‘Surpass main menu -> Edit -> Show Display Adjustment’

 

3 Fiji Plugin From Imaris Surpass 
Mainly to be used for formats which are not at all supported by Imaris or Imaris File Converter. 
Switch from Arena to an empty Surpass from main Imaris bar of Icons 

 
 

3.1 Open files with the standard Fiji ‘File – Open’ tool 
To be used first. 
 
‘Surpass Main Menu -> Fiji -> File -> Open’ 

 
When you select a file, it will be opened by Fiji and directly send to Imaris. 
 

3.2 Open files with the Fiji ‘Plugins – Bio-Formats Importer’ tool 
This gives you more options for the import. 
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‘Surpass Main Menu -> Fiji -> Plugins -> LOCI -> Bio-Formats Importer’

 
 
 
When you select a file, the Bio-Formats Import Options can be used, the datasets will be opened 
by Fiji and directly send to Imaris. 

 
 

3.3 Open files with Fiji using any Plugin and or pre-processing 
Use in case you need any other special plugin of Fiji to read the file. 

1) Open Fiji using ‘Surpass Main Menu -> Fiji -> Image from Fiji’ 
2) Use any desired function of Fiji to open and pre-process the file. 
3) Transfer the dataset using ‘Surpass Main Menu -> Fiji -> Image from Fiji’ again. 

4 Imaris File Converter 
Imaris File Converter is a stand-alone application for converting many datasets in one go. 
It is installed with Imaris but on the customer portal there is a as well a version to be installed 
alone. You do not need a license so you can install it e,g, on your file server. 
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4.1 Graphical User Interface 
 

 
 
Add files to be converted either by Drag&Drop or using the ‘Add Files’ button. 

1. Add files to be converted either by Drag&Drop or using the [1] ‘Add Files’ button. 
2. Chose were you like to store the output. If you chose [2]‘Specific Folder’ all files will be 

stored there no matter from which directory level they origin. 
3. If there are question marks in the column [3] ‘Voxel Size’ Select the lines which should get 

the same calibration and click [4]‘Set Voxel Size’. For a 2D dataset use 1. 0 will be not 
accepted by Imaris. 

4. Press [5] ‘Start All’ to start the conversion. 
 

4.2 If you do not get the desired result: 

4.2.1 Using BioFormats Readers 
ImarisFileConverter9.9 can use the open source program ImarisConvertBioformats to convert 
images from other formats to the IMS format.  
At   ‚Preferences ->  Bio-Formats -> Configuration‘ you can select per file format which converter 
you would like to use. 

 
For those formats, for which you choose ImarisConvertBioformats, file format detection is a two-
step process. When a file is added to ImarisFileConverter first it tries to detect the format. If it is a 
format for which ImarisConvertBioformats is selected as the converter, then the file will be 
processed by the plugin. This means If ImarisFileConverter can not detect the format at all this 
method will not work. 
The two-step process can take noticeably longer for some formats (compared to file format 
detection by ImarisConvert alone) as the speed with which ImarisConvertBioformats queries the 
format and the voxel size varies a lot for different file formats. 

https://github.com/imaris/ImarisConvertBioformats
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Setup: 
The program ImarisConvertBioformats itself uses the open source Bio-Formats file readers to 
read images and it uses the open source ImarisWriter to write IMS files. 
You may fist to download and then detect the plugin at Preferences ->  Bio-Formats -> 
Installation‘. 

 
 
Hint it may be that you see the above, but the plugin is already installed but just not connected 
so you may press (2) first. Only if this detection fails press (1) and install the Plugin 
ImarisConvertBioformats.exe followed by pressing (2) again. 

4.2.2 If there are problems arranging Tiff files 
It is recommended to try first to import the native file format of the acquisition device. If 
supported by Imaris this will give you the best experience since you can expect to preserve 
dimensions, calibration, and channel colours of the native format. 
You can find the supporter file formats at ‘Imaris main menu -> Help ->  Preface - Getting Started 
-> Supported File Formats’ 
 
If there is no other choice and you need to import series of tiff files the converter tries to deduct 
the correct dimensions from the file names. By default, files with the same base name and size 
are stored into the same dataset. 
If the name contains only one running number, it is interpreted as a Z stack or time series. 
If the name contains multiple running number leaded by one of the below characters, the 
characters determine which dimensions are used. 
 
Basename_C?number Channel 
Basename _T?number Time 
Basename _Z?number Slice 
Basename _X?number Column 
Basename _Y?number Row 
 
The ? can be any character or absent (_Cnumber) 
It does not distinguish between upper and lower case. 
There are more latter codes you can change at ‘Preferences – File Conversion’. 
 
A preview of which files will be used to build a IMS file you can hover over the Input entry. 

https://www.openmicroscopy.org/bio-formats/
https://github.com/imaris/ImarisWriter
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In case the automatic detection of the series still fails use [1] Settings button to open the File 
Series Reader. Please read the ‘File Series Reader’ chapter. 

 

4.3 File Series Reader 
The Imaris File Series Reader is a tool to handle series of numbered files. It allows you to group 
the files into datasets with the desired number of sections, channels and time points. The names 
and sizes of the files are used to arrange them. 

 
- Datasets which files are stored in multiple directories are not supported 
- It is available for plain Tiff files only, not e.g OME TIFF. Tiff files were Imaris finds metadata 

about the organisation of the dataset cannot be handled. 
- It is recommended to store the files of different datasets into sperate directories to simplify 

the task. 
 
The File Series Reader can be started with a selected input file [1] ‘Settings…’ 
Please note that you can as well use the tool from Arena on a thumbnail ‘RIGHT-MOUSE -> 
Configure File Series’ 
 
When started you need chose how the type of the naming of the files 

 
 
- If the file name has multiple running numbers for different dimensions chose ‘File Names with 

Delimiter’ e.g. 
retina_Ch0_layer000.tif    
retina_Ch0_layer001.tif 
retina_Ch0_layer002.tif    
retina_Ch0_layer003.tif    
retina_Ch1_layer004.tif    
retina_Ch1_layer005.tif 
retina_Ch1_layer006.tif    
retina_Ch1_layer007.tif    
retina_Ch1_layer008.tif    
retina_Ch0_layer009.tif 
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retina_Ch0_layer010.tif 
 

retina_ is the base name 
Ch0 contains the running number for the channels 
layer001 contains the running number for the layers (slices). 
 

- If the files with the identical base name have one running number chose the Tab ‘File Names 
without Delimiter’ e.g.: 

retina_001.tif    
retina_002.tif    
retina_003.tif    
retina_004.tif   
retina_005.tif 
retina_006.tif 
retina_007.tif    
retina_008.tif    
retina_009.tif    
retina_010.tif 

 
retina_ is the base name 
001 is a single running number for all files of the dataset 
 

Notes:  
 
- It is recommended to store the files of different datasets into sperate directories to simplify 

the task. 
- Datasets which files are stored in multiple directories are not supported 

 

4.3.1 File Names with Delimiter 
To be used if filenames contain multiple running numbers. E.g. retina_Ch0_layer000.tif 
 
The TIFF reader uses some default patterns _C?number _T?number _S?number. That _[letter] 
codes are used to assign the different dimensions and sort the files automatically into channels, 
time points, slices etc. 
 
_C?number -C _CH _W Channel 
_T?number   Time 
_Z?number -Z _S  Slice 
_X?number -Y   Column 
_Y?number -Y   Row 
 
The ? can be any character or absent 
It does not distinguish between upper and lower case. 
 
If the automatic assignment does not work, you can use the ‘Series Reading Sequence’ tool to 
further tune it for specific files. 
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Imaris will show the filename and at the place of the running number a menu to select how the 
number should be interpreted: 
BLANK Ignore 
X  Slices 
Y  Slices 
Z  Slices 
C  Channels 
T  Timepoints 
F (Split) Split the files into the next dataset if the number changes. 
 
Below the number of items are shown which will be assigned to the chosen dimensions. In the 
screenshot this are 2 channel and 5 Z layers. 

 
The table ‘File Arrangement’ shows a preview of the resulting first dataset which will be created. 
 
Here are a few examples: 
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First number T, second number Z -> 1 datasets with 1 channel, 2 time points and 5 Z layers will 
be created. 
 

 
First number Z, second number T -> 1 datasets with 1 channel, 2 Z layers and 5 timepoints will 
be created. 
 

 
First number ‘F- (Split) , second number Z -> 2 datasets with 1 channel and 5 Z layers will be 
created. Please note that the table show always only the layout of the first IMS dataset. 
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First number C, second number T -> 1 dataset with 2 channels, 5 time points and 1 Z layer will 
be created. 

4.3.2 File Names without Delimiter 
To be used if filenames contain a single running number. E.g. retina_000.tif 

 
[1] Oder to loop inside the dimensions.  
The available settings are: 

BLANK Ignore 
X  Slices 
Y  Slices 
Z  Slices 
C  Channels 
T  Timepoints 
F (Split) Not needed. May crash Imaris when set! 

 
At [1] you can set the dimensions used for the dataset and in which order the files are assigned 
to them. 
At [2] you can set the number of items which will be assigned to the dimension above. 
In the screenshot this is 1 dataset with 1 channel and 10 Z layers. 
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If you use multiple of the entries Imaris loops through the dimensions and assigns specified 
number of files to them in each round. The most right entry is for the inner loop and the most left 
for the outer. First the files with consecutive numbers will be added to the inner loop before the 
next dimension to the left starts to get filled. 
 
Here are some examples:  
 

 
Inner loop will be used for 2 channels. So files 01 and 02 go into the two channels of Z layer 1, 
time point 1. Middle loop is for Z layers so the files 03 and 04 go into Z layer 2, into the two 
channels. Now all dimensions of the inner two loops are filled and the outer loop starts to fill the 
second time point in the same order as the first one. 
[1] Imaris found 10 files with the same base name but we now use only 8. That means something 
is wrong with our configration of the dimensions, some files were lost after acquisition or the base 
name was not correctly detected. 
 

 
The inner loop will be used for 2 Z layers. So file 01 and 02 goes into the two layers of the 
channel 1. Since Z can hold only two items the files 03 and 04 go into the the second channel. 
Since there are 5 channels to be filled this is repeted for the remaining channels. 
The third loop is not used in this example since no dimension is assigend to the most right entry. 

4.3.3 Voxel Size and Channel colours 
At the bottom of the window you find the voxel size. 
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Set the Voxel size to have the correct calibration of the dataset. You may need to open the 
original dataset in the acquisition software to find the correct values. The calibration is very 
important to set before you start any analysis of the dataset. For a 2D dataset use 1. 0 will be 
not accepted by Imaris. 
The units, here micrometer, are a global setting in Imaris main menu ‘Preferences -> Display -> 
Unit of Length’. 
Note: The time calibration you must set after the conversion in Surpass main menu ‘Edit -> Image 
Properties… -> Geometry -> Time Point’. 
 
Typically, all channels will be displayed in red. Please open the dataset in ‘Surpass main menu ->  
Edit –> Image Properties -> Geometry -> Channel #’. 

 
 
Alternatively, you can come here by clicking in the name of the channel the ‘Display Adjustemt’ 
windows. ‘Surpass main menu -> Edit -> Show Display Adjustment’
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4.4 Command Line Version of Imaris File Converter 
there is a command line version for the FileConverter which can be used e.g. in your own scripts. 
 
It is in your Imaris and ImarisFileConverter installation folder. E,g, 
c:/program files/Bitplane/Imaris 9.9.1 
 
You get a first help by running this command from the command line: 
ImarisConvert.exe --help  
 
If you need some inspiration, you can have a look at the log files that the FileConverter creates.  
Enable the logging at: ‘Imaris File Converter -> Preferences -> Settings –> Logger’. 
There is a link (show log) in the Preferences to open the Log directly from there. 
Now convert a file and have a look into the log. 
The file will be placed on Windows at:  
"C:\Users\USERNAME\AppData\Local\Temp\ImarisFileConverter.log" 
There is a link (show log) in the Preferences to open the Log directly from there. 
 
A typical command line could look like this: 
 
C:\Program Files\Bitplane\Imaris 9.9.1\ImarisConvert.exe" -lp -i 
"D:\Source\WB-Live_F12_w1_s1_z1_t1.tif" -ii 0 -ps 8000 -nt 24 -of Imaris5 -
o "D:\MyOutput.ims" -vs "0.000 0.000 0.000" -il "D:\Test.txt" --log 
D:\temp\Log.LOG 
 
Please Note: This is really only a raw backend of the GUI so it e.g. does not warn when it 
overwrites files. 
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