Part of the Oxford Instruments Group
Expand

Frequently Asked Questions

Welcome to our frequently asked questions page, please find answers to commonly asked questions here covering topics including Hardware, License and Installation, File Import/Export, Visualisation, Analysis, Imaris XT, Settings and Troubleshooting. If your question isn't answered on this page please contact our customer support team, who will be happy to assist you further.

Hardware

The graphics card and its driver are crucial for the stability and performance of Imaris.

Please check our System Requirements for supported graphics cards. And please update the driver regularly, at least every time you install a new Imaris version.

If you plan to work with large time series we recommend investing in more than 4 GB of graphics RAM. This will allow the graphics card to cache all textures for the display so you can browse much faster through the frames.

For deconvolution, GPU processing is supported on AMD and NVIDIA cards. NVIDIA is preferred because of better performance with CUDA.

While you can run Imaris with high resolution monitor, the interactivity may be compromised due to the higher rendering calculation requirement.

Versions 9.3 9.5 9.6 9.7

Imaris implemented GPU-accelerated calculation for the ClearView deconvolution function.

GPU processing is supported on both AMD and NVIDIA cards. NVIDIA is preferred because of better performance with CUDA

The image size that Imaris can handle is not limited by RAM. If the data size/calculation requirement exceeds computer RAM, Imaris performs data caching to a hard drive.

However, data caching can slow down the processing speed. For better performance, we recommend having RAM at least twice the size of your image file.

The image size that Imaris Stitcher can handle is RAM limited. The minimum RAM requirement is around ten times the size of the largest volume overlap region. For additional Stitcher technical implementation details, please see here.

Versions 9.3 9.5 9.6 9.7

Please check System Requirements for the latest information on hardware and operating systems.

As a rule of thumb the Minimum System works for datasets within 1GB, Recommended System for datasets up to ~5 GB, and High End System for dataset 10 GB or above. The requirement may vary depending on the file shape (i.e. long time lapse or large 3D volume) and the analysis workflow.

Please contact Imaris Support if you would like to discuss your specific need.

Imaris is a multi-threaded application and many of the processing functions make effective use of multiple CPU cores. While we are working on optimizing algorithms to utilize the full power of multi-core systems with each new release, there remain some steps that are not yet fully multi-threaded. Thus, we recommend a balance between CPU speed and number of cores.

In general, we recommend fast (3 GHz+) CPUs with eight cores (16 threads) or higher.

If your multi-core CPU is not running at 100% in Windows Task Manager, not all cores are used.

It may be due to (1) the calculation is not fully multi-threaded, or (2) Imaris may need to load image data from the disk into RAM for processing. In general, disk access in Imaris will only use one thread per disk.

If you are using Windows 10 Build 1903 and newer, you can use Imaris in Windows Remote Desktop session (RDP) if you have an NVIDIA Quadro card of at least the M-Series or with AMD cards of any series (Radeon, RadeonPro or FirePro). The oldest AMD card we have tested successfully with RDP is a FirePro V7900 (released in 2011).

NVIDIA Geforce and Titan cards do not support in any Windows version the OpenGL acceleration that is essential for RDP (as of March 2020). There is no well-known workaround.

For earlier Windows 10 build (180x and earlier) or Windows 7/8 or 8.1 the only way to get Imaris working in RDP sessions is to use an NVIDIA Quadro M-Series or newer (e.g., M4000, P4000). The Quadro card driver supports OpenGL independent of the Windows version.

There are other remote desktop solutions (TeamViewer, Anydesk, etc.) that do not rely on OpenGL and may work for your system.

Please consult your IT department before installing remote desktop solutions as there might be network restrictions in place.

License and Installation

Please check Imaris Packages for the package feature comparison.

To explore additional features, please contact your local sales engineers.

Version 7.0, 7.1, 7.2, 7.3, 7.4, 7.5, 7.6, 7.7, 8.0, 8.1, 8.2, 8.3, 8.4, 9.0, 9.1, 9.2, 9.3, 9.5, 9.6, 9.7

Help > License > Available License provides the list of Imaris licenses with expiration date. If you have a permanent license, Expiration column would show ‘Never.’

Please see this step by step satellite license tutorial and the written guide below. Core facility users, please check with your core facility manager regarding your core’s specific satellite license usage policy.

(1) Go to the Imaris Customer Portal

(2) Log in with your registered email

(3) On the left-hand side, click on 'Satellite Licensing'

(4) Follow the instructions for generating the order-id for the satellite license

(5) Now follow the Installation Instructions for installation and licensing guidance.

Note: Satellite license duration is set under the Manage User page, but only the site manager has access to the Manage User page within the Customer Portal

Please contact us for Imaris license migrations and we will follow up to complete the process with you:

In the email, please include the following information, if possible:

  • Imaris OrderID: You can find it on the invoice, the license letter you received when the license was purchased, or from the Customer Portal on the Product Status page.
  • Current Computer Host ID: Available from the Customer Portal on the Product Status page or within Imaris follow File > Preferences > System > System Host ID.
  • (3) New Computer Host ID: Install Imaris on the new computer and click on Imaris Configurator > Help > Show System Information to find the new computer’s Host ID. Customers based in Europe, the Middle East, Africa, and India please request the migration agreement from admin@bitplane.com
  • Customers based in North and South America please contact ussupport@bitplane.com
  • Customers based in Asia please asiasupport@bitplane.com

You can access Imaris Installers from the Customer Portal on the Download page.

To access earlier versions, go to the Download page and click on the “Software release archive”.

Yes! However, please be aware that some functions/analyses may not be compatible across different versions.

Please see the Imaris release notes for changes by version.

Yes! Imaris Viewer is a FREE 3D/4D microscopy image viewer for viewing raw images as well as those analysed within Imaris and saved in the IMS format. Imaris Viewer lets you visualize raw images as well as images and objects generated in Imaris.

File Import/Export

The IMS file format is based on the Hierarchical Data Format (HDF5) that is designed to work with huge multidimensional data and is optimized to allow extremely fast visualization of huge volume data. To facilitate this, the format stores not only the original image data but also lower resolution versions of the original data.

For additional information, please see here.

Yes! ImarisWriter allows you to quickly write image files suitable for high performance visualization and analysis in the Imaris5 File Format.

Versions 7.6, 7.7, 8.0, 8.1, 8.2, 8.3, 8.4, 9.0, 9.1, 9.2, 9.3, 9.5, 9.6, 9.7

Imaris can export Surfaces in the *.wrl and *.iv formats (by 3D View > Export Selected Objects. These formats are compatible with MeshLab and other 3D animation softwares. This short tutorial shows the export and import steps of wireframe models.

Versions 9.3 9.5 9.6 9.7

When converting an image file into the IMS format either in Imaris Arena or by the ImarisFileConverter, new IMS file is generated with the same name as the original image file and the original file is not modified or deleted.

If both the IMS file and the original file exist in the same folder, then only the IMS file will appear in the Arena view.

In most cases you will be able to read IMS files written by older Imaris versions into later ones. There are some limits:

  • IMS files version 3.0 (written, e.g., by Imaris 3.0 to 4.5) cannot be opened directly in Imaris 9.5 or later. Workaround:
    • remove the. ims extension
    • observe the folder in Arena
    • double-click the file to convert it to ims5
  • Surfaces written in versions before 9.0 can be opened in newer versions, but with reduced functionality. Workaround: In case you have not done any manual editing, use Surfaces > Creation tab > Recompute to recreate them in the new format.

IMS files written in newer software versions may not be read in earlier Imaris versions. When you have problems, you might have partial success by using ‘Save As’ or ‘Export’ where you can choose an older file format in the ‘Save as type’ field in the newer version. It is likely that not all parts of the Imaris scene will be saved in the older format.

Versions 9.3 9.5 9.6 9.7

We support file conversion from TIFF and most proprietary files from major microscopy vendors. The complete list of files that can be directly converted is located at: Help > Reference Manual > Supported File Formats. To open an image file in Imaris it first needs to be converted into the IMS format using the Imaris File Converter or within Imaris Arena.

Visualization/Snapshot/Animation

Versions 7.6, 7.7, 8.0, 8.1, 8.2, 8.3, 8.4, 9.0, 9.1, 9.2, 9.3, 9.5, 9.6, 9.7

This tutorial shows how light sources work in Imaris, and how to operate multiple light sources in your scene.

Versions 7.6 7.7 8.0 8.1 8.2 8.3 8.4 9.0 9.1 9.2 9.3 9.5 9.6 9.7

This tutorial shows one way to create a simple animation going up and down through your 3D image.

Versions 5.7 6.0 6.1 6.2 6.3 6.4 7.0 7.1 7.2 7.3 7.4 7.5 7.6 7.7 8.0 8.1 8.2 8.3 8.4 9.0 9.1 9.2 9.3 9.5 9.6 9.7

This tutorial shows how to create a customized color look up table (LUT) for your data.

Versions 8.4 9.0 9.1 9.2 9.3 9.5 9.6 9.7

(1) For version 9.5 and older ensure that Offscreen Rendering is checked ON File > Preferences > Display > check ‘Offscreen Rendering (for saving Snapshots and Movies)’.

(2) File > Preferences > Snapshot > check ‘Transparent Background.’ Select either ‘TIFF’ or ‘PNG’ as file type.

Versions 7.0 7.1 7.2 7.3 7.4 7.5 7.6 7.7 8.0 8.1 8.2 8.3 8.4 9.0 9.1 9.2 9.3 9.5 9.6 9.7

Edit > Image Properties > Voxel Size allows you to check and/or modify the voxel size.

Edit > Image Properties > All Equidistant. allows you to set the time interval.

Versions 7.0 7.1 7.2 7.3 7.4 7.5 7.6 7.7 8.0 8.1 8.2 8.3 8.4 9.0 9.1 9.2 9.3 9.5 9.6 9.7

You can turn on or off Scale bar display from File > Preferences > Display > Coordinate Axis/ Scale Bar / TimeColor Bar section.

Move the cursor close to the scale bar and you will see it change shape. Now drag left/right to decrease/increase scale bar length.

Move the cursor close to the scale bar and drag up/down to increase/decrease scale bar thickness and the font size of the scale bar label.

Versions 8.0 8.1 8.2 8.3 8.4 9.0 9.1 9.2 9.3 9.5 9.6 9.7

You can control the image angle and zoom using the following steps:

  • Image Processing > Camera Functions > Set the Angle of the Camera allows you to set specific rotation angles for individual images.
  • Image Zoom percentage can be set at the lower right of the Imaris window.

Versions 9.1 9.2 9.3 9.5 9.6 9.7

You can load multiple datasets using File > Add Image. Each image’s position can be controlled by its corresponding Frame and object detection can be done on all available channels.

For additional tutorials and application examples, please see Imaris 9.1 Release Notes.

Analysis

Versions 9.6, 9.7

Imaris allows you to classify objects by machine learning that utilizes all standard statistics calculated by Imaris and additional ‘machine learning statistics,’ that provide more information about the local intensity landscape. For additional tutorials and application examples, please see the Imaris 9.6 release notes and this Home School recording.

Three things to consider when deciding which object works the best for your analysis:

  • The object shape – Can it be approximated by a sphere? Is it better modelled by filament?
  • Desired statistical output
  • Dataset size/complexity – If processing speed is a concern, stay with simpler models

For additional details, please watch this Home School recording that provides an overview of all Imaris objects.

Versions 7.0 7.1 7.2 7.3 7.4 7.5 7.6 7.7 8.0 8.1 8.2 8.3 8.4 9.0 9.1 9.2 9.3 9.5 9.6 9.7

(1) Go to File > Preferences > Statistics, and check if specific statistical values are selected.

(2) Go to the Statistics tab under the component of interest, select the statistic value, and click ‘Export Statistics on Tab Display to File.’ Alternatively, you can export all available statistics by clicking ‘Export All Statistics to File.’

(3) Statistics can also be saved from Vantage for the values used for plotting.

Versions 7.6 7.7 8.0 8.1 8.2 8.3 8.4 9.0 9.1 9.2 9.3 9.5 9.6 9.7

This tutorial walks you through the process of creating a custom-shaped region in your 2D or 3D image.

For more in-depth discussion on the Surface Contour topic, please watch this Home School recording.

Versions 7.6 7.7 8.0 8.1 8.2 8.3 8.4 9.0 9.1 9.2 9.3 9.5 9.6 9.7

Follow this tutorial to learn how to precisely position the vertices of contour lines, how to edit only a few vertices of an otherwise complete contour, and how to translate, rotate, and scale contour lines.

Versions 5.7 6.0 6.1 6.2 6.3 6.4 7.0 7.1 7.2 7.3 7.4 7.5 7.6 7.7 8.0 8.1 8.2 8.3 8.4 9.0 9.1 9.2 9.3 9.5 9.6 9.7

Filter offers a quick and easy way to find objects with certain statistical values. The selected objects can be labelled, duplicated, or removed for various application needs.

This tutorial shows you the various ways to use the Filter tool.

Versions 9.3 9.5 9.6 9.7

If you run Batch analysis, the aggregated statistics results can be accessed from Arena > Folder Batch History > Export Statistics to csv file.

If you have manually segmented several images, or segmented them automatically one-by-one, it is still possible to aggregate the statistics from several different images into a single .xls/.csv/.xml by following these steps.

Versions 8.0 8.1 8.2 8.3 8.4 9.0 9.1 9.2 9.3 9.5 9.6 9.7

(1) After creating an object, go back to the Creation tab

(2) Click ‘Store Parameters for Batch...,’ check Store Location ‘Favorite Creation Parameters’

(3) Go to File > Preferences > Creation Parameters, click ‘Export...’, share the saved *.icpx file

(4) *.icpx file can be imported to other computers with Imaris by File > Preferences > Creation Parameters > Import...

Imaris provides many tools to study colocalization. Depending on the signal characteristics you can choose to use either intensity-based colocalizations tools to quantify diffuse signals or object-based colocalization tools for structures that can be represented as objects.

This short tutorial video shows the comparison between intensity and object-based colocalization. For more in-depth tutorials and application examples, please see here.

Version 9.3 9.5 9.6 9.7

  • In the file system, create folders for the different groups of datasets
  • Move or copy the datasets into the folders
  • In the parent folder, create a new Batch Pipeline
  • Right click on the Batch Pipeline and select ‘Run Batch including Subfolders’
  • After processing is finished select the folders with the processed datasets
  • Click ‘New Plot’

For more details on Vantage plot comparison, please see this Imaris HomeSchool recording.

Version 9.3 9.5 9.6 9.7

  • Make sure the objects in the 3D View Scene tree of each dataset have a name that reflects the group they belong to. For example:
    • ‘Surface 1 Group A’ would be the identical name for Surfaces which need to be sorted in Group A
    • ‘Surface 1 Group B’ would be the identical name for Surfaces which need to be sorted in Group B
  • In Arena select all datasets by pressing CTRL-A and mouse select (*All datasets of all groups must be in the same folder!)
  • Click ‘New Plot’ to show the result

Results:

For more details on Vantage plot comparison, please see this Imaris HomeSchool recording.

Version 5.7 6.0 6.1 6.2 6.3 6.4 7.0 7.1 7.2 7.3 7.4 7.5 7.6 7.7 8.0 8.1 8.2 8.3 8.4 9.0 9.1 9.2 9.3 9.5 9.6 9.7

2D datasets are handled like 3D datasets, so you get the same statistics but be aware of the interpretation of these values:

Area

The area statistic refers to 3D surface area even for a 2D dataset. Imaris creates a surface around the voxels, including the top, bottom, and side. The reported area will consider all these faces of the surface.

Instead, please use 'Number of Voxels' and multiply it by the XY size of a pixel to get the 2D area value.

Volume

Imaris computes a 3D Volume which takes the Z voxel size into account as given at 'Surpass - Edit - Image Properties - Geometry - Voxel Size - Z'.

If you set Z voxel size = 1, this value will reflect the 2D area. *There may be a rounding error for very small Surface objects.

Imaris XT

The ImarisXT Python interface supports Python 3.7 and Python 2.7.

If you are running a supported Python version:

  • Go to File > Preferences > CustomTools
  • Add Python path to Python 2.7 Application or Python 3.7 Application
  • Add the folder(s) that contains your Python scripts to the XTension Folders. For testing purpose, you can add built-in Python scripts at the following locations:

C:\Program Files\Bitplane\Imaris x64 X.X\XT\python2\ (for Python 2.7 scripts)

C:\Program Files\Bitplane\Imaris x64 X.X\XT\python3\ (for Python 3.7 scripts)

For additional details, please watch this Imaris HomeSchool recording.

Versions 8.3 8.4 9.0 9.1 9.2 9.3 9.5 9.6 9.7

Please see this short tutorial video for how to activate ImageJ and MATLAB plugins.

(1) Go to File > Preferences > CustomTools

(2) Check whether MATLAB Compiler Runtime (MCR) items are orange or white. White means it has been installed and connected properly. If they are orange, there should be a download link for the MCR. Please download and install the proper MCR version based on Imaris version. We recommend choosing the default settings and the default installation path.

Imaris 9.6: MCR v9.8

Imaris 8.3-9.5: MCR v8.4

Imaris 8.2 and below: MCR v7.11

*You can also access MCR installers from the Customer Portal and its Download page.

(3) Once installed, built-in XTensions are ready to use and all MATLAB symbols under the Image Processing menu should turn from grey to brown in color.

Versions 8.3 8.4 9.0 9.1 9.2 9.3 9.5 9.6 9.7

  • Download the XTension package from Imaris Open. Check the file type.

*.exe and *.xml file requires MATLAB Compiler Runtime (MCR).

*.m requires a full MATLAB installation.

*.py requires Python.

Note: Different XTensions may require different versions of MATLAB/Python or specific versions of Imaris to run properly. Some XTensions may also require specific modules not included in every user’s license. Please check the XTension documentation or contact the developer directly.

  • Unzip the XTension package to the XTension folder
  • Open Imaris > File > Preferences > CustomTools > add the location of XTension folder

Note1: For user-defined XTension folders make sure to copy the following file(s) from the Imaris built-in XTension folder:

MATLAB XT (C:/Program Files/Bitplane/Imaris x64 X.X.X/XT/matlab) - ImarisLib.jar

Python XT (C:/Program Files/Bitplane/Imaris x64 X.X.X/XT/python3) - ImarisLib.py, Imaris folder, ImarisServer folder, private folder (or add these folders to the PATH).

Note 2: Imaris can access files within XTension Folders, but not within their sub-folders.

Versions 8.0 8.1 8.2 8.3 8.4 9.0 9.1 9.2 9.3 9.5 9.6 9.7

Please see this short tutorial video for how to activate ImageJ and MATLAB plugins.

(1) Download and install Fiji

(2) Go to File > Preferences > CustomTools

(3) Add the Fiji path to ImageJ/ Fiji Application.

(4) To test, open an image in Imaris, use Fiji > Image to Fiji. The same image will open in Fiji.

Versions 8.3 8.4 9.0 9.1 9.2 9.3 9.5 9.6 9.7

If you have a full MATLAB installation where the default path was selected, Imaris should automatically identify the MATLAB path and no additional steps are required. You can check and edit the MATLAB path from File > Preferences > Advanced > CustomTools > MatlabPath.

Settings

Versions 9.3 9.5 9.6 9.7

Texture cache affects rendering responsiveness. The default value is the physical RAM of your graphics card, and it should work well most of the time. For graphics card with large RAM (>8GB), reducing this value may sometimes increase responsiveness.

You can adjust the texture cache used by Imaris from File > Preferences > Display.

You can adjust RAM used by Imaris from File > Preferences > Calculation.

The default value is set at half of the system RAM. When modifying this value, please make sure the system has sufficient RAM to run the machine. If you have 128 GB RAM, set this value at 100 GB or lower to ensure system stability.

You can change data cache location from File > Preferences > Calculation.

The default location is usually set to the C drive. If you have multiple hard drives, we recommend setting the data cache location to the faster drive (PCIe SSD) and to avoid using the system drive as a cache drive.

Imaris can write in parallel to different paths if more than one path is added. Please be aware that if multiple drives are used as a cache drive, the one with fewer free space will limit the usable space on the others as well.

If you are an administrator, you can force some settings to apply to all users from File > Preferences > Imaris Administrator > System Preferences. Remove the check mark 'Is editable by Users' to enforce it on all current and new users.

Settings that can be set system-wide include number of threads, texture cache, RAM limit, data cache paths.

To reset user settings:

(1) Open Imaris, make sure only one instance is running

(2) File > Preferences > Reset Preferences…

(3) Restart Imaris

Note that some settings are only accessible from Registry. We do not recommend that users edit the registry in most cases. If you need assistance, please contact your regional Support Team.

Trouble Shooting

To learn more about a specific function, right click on the function in Imaris and click ‘Show Help’ to bring you to a content-specific location in the Reference Manual.

You can also go to Help > Reference Manual to browse or search for specific functions.

For statistical value definitions go to Help > Statistics Reference.

If you cannot find the information you are looking for please contact your regional Support team.

(1) Ensure you are not using the integrated Intel graphics card as it is not compatible with Imaris and not supported. In Windows 10, if you have a dedicated graphics card you can set it as the preferred graphics card from ‘Graphics settings”. Under Graphics settings, choose Imaris to set the preference. Select ‘High performance’ or the desired graphics card. 

If you are not using Windows 10, the NVIDIA and AMD control panels will allow you to create an application profile for Imaris to use the preferred card.

(2) Make sure your graphics card has at least 1GB of graphics RAM available. We recommend using a graphics card with at least 4GB of graphics RAM for decent performance.

Reducing the Quality of the Volume object can also help to avoid flickering on graphics cards with limited graphics RAM. The Quality slider can be adjusted in the ‘Settings’ tab of the Volume component.

(3) Ensure the texture cache is set correctly in File > Preferences > Display. The value of ‘Texture Cache’ should match the amount of your graphics RAM.

(4) Update your graphics driver by going to either the AMD or NVIDIA website and downloading the latest version of your card.

(1) The message can appear if you are using a Windows machine. Please make sure you are not using the integrated Intel graphics card as it is not compatible with Imaris and therefore not supported.

(2) This message can also appear if you have too many channels enabled simultaneously. While Imaris can handle dozens of channels internally, most graphics cards are usually only able to display 8 channels at the same time.

(3) It may be caused by a driver issue. Update your graphics driver by going directly to either the AMD or NVIDIA website and downloading the latest driver version for your specific card.

(4) If you are logged in on a Windows machine remotely via an RDP session you might have a graphics card and Windows version combination that does not support OpenGL acceleration in RDP sessions. Please see section ‘Can I run Imaris in Windows Remote Desktop (RDP)?’ [h2 link or whatnot please] for more information.

MacOS can complain about the Imaris installer package for not being able to scan it for malicious software. This is one of the protection systems from recent MacOS releases. If you downloaded Imaris installer from our Customer Portal, rest assured that the Imaris installer is clean and does not contain malicious software.

To install Imaris anyway, right click the installer package to bring up the context menu. Select ‘Open’.

MacOS will then bring up a similar dialog with the ‘malicious software’ warning but will now give you the option to open the package. Click ‘Open’ to continue the rest of the installation steps.